source: BAORadio/libindi/v1/debian/rules @ 597

Last change on this file since 597 was 490, checked in by campagne, 14 years ago

import libindi (JEC)

File size: 1.0 KB
Line 
1#!/usr/bin/make -f
2clean::
3        dh_testdir
4        dh_clean
5        rm -rf debian/tmp
6
7d:=debian/tmp
8version:=0.6
9DEB_HOST_ARCH=$(shell /usr/bin/dpkg-architecture -qDEB_HOST_ARCH)
10
11build: 
12        mkdir -p $(d)
13        cmake -DCMAKE_INSTALL_PREFIX=$(d)/usr .
14
15install: build
16        dh_testdir
17        dh_testroot
18        dh_clean -k
19        dh_installdirs
20        make install
21        ln -sf /usr/bin/indi_lx200generic $(d)/usr/bin/indi_lx200classic
22        ln -sf /usr/bin/indi_lx200generic $(d)/usr/bin/indi_lx200autostar
23        ln -sf /usr/bin/indi_lx200generic $(d)/usr/bin/indi_lx200_16
24        ln -sf /usr/bin/indi_lx200generic $(d)/usr/bin/indi_lx200gps
25        ln -sf /usr/bin/indi_lx200generic $(d)/usr/bin/indi_lx200ap
26
27binary-indep:
28        # nothing to do
29
30binary-arch: build install
31        dh_testdir
32        dh_testroot
33        dh_installdocs
34        dh_installchangelogs
35        dh_install -s --sourcedir=debian/tmp
36        dh_link -s
37        dh_compress
38        dh_fixperms
39        dh_makeshlibs
40        dh_installdeb
41        dh_gencontrol
42        dh_installdeb -s
43        dh_shlibdeps -s
44        dh_gencontrol -s
45        dh_md5sums -s
46        dh_builddeb -s
47
48binary: binary-indep binary-arch
49.PHONY: build clean binary-indep binary-arch binary
Note: See TracBrowser for help on using the repository browser.